# Table of Contents

## Section 1: Working With Charts ................................................................................................................................. 1

- Lesson 1.1: Working With Charts, Part 1 .......................................................................................................................... 2
  - Creating a Chart ............................................................................................................................................................. 2
  - Formatting a Chart ......................................................................................................................................................... 4
  - Modifying Charts with the Layout Tab .......................................................................................................................... 11
  - Manipulating a Chart ..................................................................................................................................................... 24
  - Enhancing a Chart with Shapes and Graphics ........................................................................................................... 31

## Lesson 1.2: Working with Charts, Part 2 ............................................................................................................................ 35
  - Changing the Type of Chart ........................................................................................................................................... 35
  - Changing the Source Data ............................................................................................................................................ 38
  - Working with the Chart Axis and Data Series ................................................................................................................ 41
  - Saving a Chart as a Template ........................................................................................................................................ 49

## Section 2: Getting the Most From Your Data .................................................................................................................... 51

- Lesson 2.1: Getting the Most from Your Data ................................................................................................................... 52
  - Using Automatic Outlining ........................................................................................................................................... 52
  - Displaying and Collapsing Levels ................................................................................................................................. 54
  - Grouping Data Manually ................................................................................................................................................. 56
  - Creating Subtotals ........................................................................................................................................................... 59

## Lesson 2.2: PivotTables ..................................................................................................................................................... 63
  - What is a PivotTable? ....................................................................................................................................................... 63
  - Creating a PivotTable ...................................................................................................................................................... 64
  - Creating a PivotTable Frame ........................................................................................................................................... 68
  - Specifying PivotTable Data ............................................................................................................................................ 71
  - Rearranging PivotTable Data .......................................................................................................................................... 74

## Lesson 2.3: More About PivotTables ............................................................................................................................... 81
  - Modifying PivotTable Calculations ............................................................................................................................... 82
  - Formatting a PivotTable .................................................................................................................................................. 84
  - Refreshing a PivotTable ................................................................................................................................................. 88
  - Charting a PivotTable .................................................................................................................................................... 89
  - Creating a PivotTable Based on External Data ........................................................................................................... 96

## Lesson 2.4: Exploring Scenarios ...................................................................................................................................... 104
  - What is a Scenario? ......................................................................................................................................................... 104
  - Creating a Scenario ........................................................................................................................................................ 105
  - Creating a Scenario Summary Report ........................................................................................................................... 108
  - Saving Multiple Scenarios ........................................................................................................................................ 110

## Lesson 2.5: What If Analysis .......................................................................................................................................... 111
  - Using a One and Two Input Data Table ........................................................................................................................ 111
  - Using Goal Seek ............................................................................................................................................................ 120
  - Using Solver ................................................................................................................................................................. 122

## Index ........................................................................................................................................................................................................ 131
Section 1: Working With Charts

In this section you will learn how to:

- Create charts
- Format charts
- Enhance charts with drawing tools
- Change the chart type
- Change the source data for a chart
- Work with chart axes and data series
- Create a chart template
Lesson 1.1: Working With Charts, Part 1

Sometimes it can be hard to discern patterns or relationships in your data from basic tables of numerical entries. Excel 2007’s powerful chart tools can help you create a more meaningful representation of your data, by making it easy to build professional looking charts.

In this lesson you will learn how to create, format, and manipulate a chart. You will also learn how to enhance your chart with Excel’s drawing tools and how to add titles and tables.

In the practice exercise you will create and modify a chart, step by step.

Creating a Chart

One of the major changes in Excel 2007 is the way that charts are created and handled. In previous versions of Excel, charts were often created with the chart wizard. In Excel 2007, a new approach is taken in hopes that a professional looking chart can be created in just a few clicks. Instead of a chart wizard, Excel 2007 provides a series of chart buttons and controls on the Insert tab.

Before you create a chart, first consider the type of chart that you require. Pie charts and bar charts are good for showing comparisons. Line graphs can be useful for showing trends and
plotting relationships between variables. If you want a really visually interesting chart, consider a three dimensional type.

To create a chart, first select the data that you want to base your chart on.

<table>
<thead>
<tr>
<th>Region</th>
<th>Sales</th>
<th>Profits</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>$100,000.00</td>
<td>$25,000.00</td>
</tr>
<tr>
<td>South</td>
<td>$150,000.00</td>
<td>$32,000.00</td>
</tr>
<tr>
<td>East</td>
<td>$68,000.00</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>West</td>
<td>$176,000.00</td>
<td>$50,000.00</td>
</tr>
</tbody>
</table>

Our aim here is to create a pie chart. To do this, we have selected the region labels and the sales data. The region labels will give us category headings for our chart and the sales figures will comprise the actual data for our chart.

Once you select the data, you can proceed by clicking the Insert tab to display the Insert Tab. On the Insert tab, click the Pie Charts button to display a menu of possible pie charts. For this example, we will click on the Exploding 3-D Pie Chart option.
This action creates an exploding 3-D chart in the spreadsheet, showing comparative slices for the sales per region.

![Excel Spreadsheet with Chart](image)

**Formatting a Chart**

Even after you create a chart, you can still alter its appearance. The easiest way to do this is to single click inside the box (chart area) that surrounds the chart. When you do this, you will see the words Chart Tools appear in the Excel title bar.

![Excel Chart Tools](image)

If you click on the words Chart Tools, you will see the Design tab appear.

![Excel Chart Design Tab](image)

This tab provides you with a variety of quick and easy chart reformatting options. At the far left of the tab, there is a button to completely change the chart type if you wish.

For now, we will only worry about changing the general format of the chart.
To begin, if you right-click on the chart legend and choose Format Legend from the pop-up menu, you will see a box appear around it, and you will see a Format Legend dialog box on your Excel screen.

In this dialog box, you can select any one of the legend position radio buttons to place the legend in the position specified. If you click the Fill option on the panel on the left, you will see options pertaining to the legend background fill color.
As an example, if you select the Gradient Fill radio button, you will see options for fill gradients.
If you click the Presets arrow, you can choose a fill gradient for the legend background from a drop menu.

Here you can see the results of selecting the top radio button for the legend position, and a gradient fill for the legend background.

If you click in the area of the box that is close to the chart itself, you will see a second inner box surround the chart. This box defines the plot area of the chart. (In the image above, you can see a thin line forming a box that is inside the heavy outer box.)

If you right click inside the plot area and select Format Plot Area from the pop-up menu, you will display a Format Plot area dialog box.
You can use the options in this dialog in the same way as the Format Legend dialog.

Here is the same chart with the plot area formatted as a parchment gradient.

Finally, if you right click on the blank white area of the chart (around the sales heading and legend) and then select Format Chart Area from the pop-up menu, you will display the Format Chart Area dialog box.

Just as in the previous two examples for the legend and plot area, you can use this dialog box to format the Chart Area. Just select a radio button for Gradient fill, Solid fill, or No fill, and then choose from the available options.
The following image shows the pie chart from above with a solid fill color added to the chart area.

As mentioned at the beginning of this formatting discussion, clicking inside the box (chart area) around a chart will allow you to display the Design tab.

In the Design tab, you will see a Chart Styles group that is fantastic for reformatting your chart. With these style buttons, Excel 2007 can provide professional looking charts in just a few clicks.

The styles available in the Chart Styles group have been carefully composed to use complementary colors, shading, and formatting. It is most often the case that a quick style will produce a better looking chart than manual formatting, and with less time and effort!

You can cycle through the quick styles by clicking the buttons and watching your chart’s formatting change. You can use the scroll bar at the right of the group to display several more style options.
More often than not, the quick styles buttons will provide a formatting option that you will find quite satisfying.

Here is the same chart that we have been using, after being formatted with a quick style.
If you single click on the title of the chart, a box with a thin border will form around the title. If you then double click on the title, formatting options will be displayed.

![Image of a chart with a title box and formatting options]

You can use these options to align your title, bold your title, italicize it, change the font color, and more.

**Modifying Charts with the Layout Tab**

As you already know, when you create a chart in Excel 2007, there will be new tabs introduced on the user interface. For example, the Design tab (discussed previously) becomes available when you select the chart. You can use the buttons on the Design tab to quickly change the overall appearance and style of your chart.

Another tab that can be very helpful when working with charts is the Layout tab. When you create a chart, and select it by clicking on it, you should see a Layout tab near the top of the Excel 2007 screen. Click the word Layout to see this tab’s options.

![Image of the Layout tab]

The most important sections of the Layout tab (in terms of charts) are the Labels group, the Axes group, the Background group, and the Analysis group.
To see how these tools work, take the following Excel chart as an example.

If we click on the chart to select it, we can then click the Layout tab to see what layout options we have for this chart.

In the Layout tab, if you click on the Chart Title Button (in the Labels group), you will reveal a small menu of title options.

Currently the chart in this example has no title, so there are two options on this title menu that we can use. You can display a title above the chart by clicking the Above Chart option, or you can place a title over the chart by clicking the Centered Overlay option.
Let’s use the Centered Overlay title.

If we decide we don’t like that one, we can easily switch to the Above Chart option.

Once you have chosen a title option, you can click on the words Chart Title to display a cursor. When the cursor appears, you can type whatever text you want for your chart title.

You may have noticed a More Title Options item at the bottom of the title menu. If you click this item, a Format Chart Title dialog box will appear.
This will allow you to change virtually every aspect of your title.

If you click the Legend button on the Layout tab, a series of options for modifying the chart legend will appear.

Clicking on any of these options will implement the particular style of legend described.

You should notice that each legend option has a small icon showing the location of the legend in relation to the chart.
If you want to apply labels directly to the data in the chart, click the Data Labels button.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Turn off Data Labels for selection</td>
</tr>
<tr>
<td>Center</td>
<td>Display Data Labels and position centered on the data point(s)</td>
</tr>
<tr>
<td>Inside End</td>
<td>Display Data Labels and position inside the end of data point(s)</td>
</tr>
<tr>
<td>Outside End</td>
<td>Display Data Labels and position outside the end of data point(s)</td>
</tr>
<tr>
<td>Best Fit</td>
<td>Display Data Labels and position with Best Fit</td>
</tr>
</tbody>
</table>

Once again, the small images that accompany each option will give you a rough idea of what the results of the given option will look like.

Here is the chart without data labels.
Here is the same chart after adding a title and data labels. The chart was also resized by dragging with the mouse in order to make the data labels legible.

The Axes button will provide you with several options for modifying the chart axes.

Notice that there are two main options labeled Primary Horizontal Axis and Primary Vertical Axis. Each of these two main options contains a submenu of modification options.
These submenus allow you to change the scale and numerical values used on the axis to coordinate the data.

The Gridlines button (also found in the Axes group) will allow you to add or remove Minor and Major Gridlines to and from your chart. You can add horizontal gridlines, vertical gridlines, or both if you wish. The gridlines will represent the axis units on the chart to give you a clearer picture of the specific value of the data at a given place in the chart.

Here is the same chart as before, with minor horizontal gridlines added.
You can also add a data table to your chart by using the Data Table button on the Labels group in the Layout tab.

A data table will help to clarify the meaning of your chart by displaying the data groupings in your chart in tabular form.

The Trendline button in the Analysis group can be useful for pointing out a specific behavior or trend in your chart’s data.
Under this button, you will see a number of options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Removes the selected Trendline or all Trendlines if none are selected</td>
</tr>
<tr>
<td>Linear Trendline</td>
<td>Adds/sets a linear Trendline for the selected chart series</td>
</tr>
<tr>
<td>Exponential Trendline</td>
<td>Adds/sets an Exponential Trendline for the selected chart series</td>
</tr>
<tr>
<td>Linear Forecast Trendline</td>
<td>Adds/sets a linear Trendline with 2 period forecast for the selected chart series</td>
</tr>
<tr>
<td>Two Period Moving Average</td>
<td>Adds/sets a 2 Period Moving Average Trendline for the selected chart series</td>
</tr>
<tr>
<td>More Trendline Options...</td>
<td></td>
</tr>
</tbody>
</table>

Once again, the image accompanying a given option shows a preview of what the option may look like when implemented.

If you want to add error bars to your chart data (to show a range around the values depicted in the chart that the data may or may not assume) just click on the Error Bars button.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Removes the Error Bars for the selected series or all Error Bars if none are selected</td>
</tr>
<tr>
<td>Error Bars with Standard Error</td>
<td>Displays Error Bars for the selected chart series using Standard Error</td>
</tr>
<tr>
<td>Error Bars with Percentage</td>
<td>Displays Error Bars for the selected chart series with 5% value</td>
</tr>
<tr>
<td>Error Bars with Standard Deviation</td>
<td>Displays Error Bars for the selected chart series with 1 standard deviation</td>
</tr>
<tr>
<td>More Error Bars Options...</td>
<td></td>
</tr>
</tbody>
</table>
Here is the same chart as before with 5% error bars added to it. The error bars show the values that the data columns could assume, if we have an estimate of 5% error.

If you are working with 3-D charts, the Background group has some useful and convenient options.

Let’s take the following 3-D chart as an example.
If you click the Chart Wall button on the Layout tab in the Background group, you will see options for showing or clearing the chart wall. The following image shows the same chart as above, with the chart wall cleared.

As you can see, the chart wall represents the back plane and bottom plane of the chart. These areas show the units that the chart data is measured by. (If you clear the chart wall, the data units and gridlines will remain, just the fill color will be removed.)

The chart floor, on the other hand, represents the bottom or side plane of the chart, where the data labels are shown. Here is the same chart with the wall fill color added and the floor fill color cleared. This was done with the Chart Floor button.
The orientation of the chart floor and chart wall may depend on the type of chart that you create. Here is a 3-D chart with the floor removed.

Here is the same chart with the floor added. As you can see, the orientation of the floor and wall of the chart differs from the chart in the previous example.
When you are working with 3-D charts, you can also use all of the options in the Labels group and the Axes group.

![Image of Labels group with options](image)

This Labels group was discussed previously in the context of 2-D charts. The buttons and menus work with 3-D charts in a similar way. Here is a 3-D chart that has been modified with the Layout tab and Design tab.

![3-D chart modified with Layout tab](image)

Remember, the results you get when you use the buttons on the Layout tab may vary between chart types, different sized charts, and between 2-D and 3-D charts.

It is usually fairly easy to undo a change that you make to a chart, so don't be afraid to experiment with the Layout tab.
Manipulating a Chart

Sometimes it may be necessary to resize or even move your chart around in your spreadsheet. To do this, first single click in the chart area to display the chart area border.

<table>
<thead>
<tr>
<th>Region</th>
<th>Sales</th>
<th>Profits</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>$100,000.00</td>
<td>$25,000.00</td>
</tr>
<tr>
<td>South</td>
<td>$150,000.00</td>
<td>$32,000.00</td>
</tr>
<tr>
<td>East</td>
<td>$68,000.00</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>West</td>
<td>$176,000.00</td>
<td>$50,000.00</td>
</tr>
</tbody>
</table>

If you place your mouse pointer on the corner of the chart border and let it hover, you will see your pointer turn into a double headed arrow.
If you drag the chart corner with your mouse, you can resize the chart.

Dragging your mouse horizontally will resize the length of the chart. Dragging your mouse vertically will resize the height of the chart. Finally, dragging your mouse diagonally will resize both dimensions of the chart.

If you look carefully at the sides of the chart border, you will see a series of four dots. If you let your mouse pointer hover over these dots, you will see a double headed arrow.
You can drag these side edges (with the double headed arrow pointer) to increase the length or height of your chart.

<table>
<thead>
<tr>
<th></th>
<th>Region</th>
<th>Sales</th>
<th>Profits</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>North</td>
<td>$1,000,000.00</td>
<td>$25,000.00</td>
</tr>
<tr>
<td>3</td>
<td>South</td>
<td>$1,500,000.00</td>
<td>$30,000.00</td>
</tr>
<tr>
<td>4</td>
<td>East</td>
<td>$650,000.00</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>5</td>
<td>West</td>
<td>$1,750,000.00</td>
<td>$50,000.00</td>
</tr>
</tbody>
</table>
If you drag the corner of the chart inwards toward the center, you will make the chart smaller.

To move the chart, let your mouse pointer hover over the one of the sides of the border, or over the top or bottom edge of the border.
When you see your mouse pointer turn into two crossed arrows, you will be able to move the chart around your screen by mouse dragging.

Here, the chart has been resized (smaller) and relocated (dragged) underneath the data.
If you want to make a chart an object in another worksheet, or move the chart to a sheet of its own, do the following.

First, right click on the chart and choose Move Chart from the drop down menu.

This will display the Move Chart dialog box.

In this example, the New Sheet radio button has been selected, which will place the chart in a new sheet called Chart1. (You can enter whatever name you like for the new sheet.)
After you are ready, click the OK button to move the chart.

The chart has been now been moved to a sheet of its own.

Note that you can also click the Move Chart button in the Design tab to display the Move Chart dialog box.

This time, if you select the Object In radio button, you can specify an existing sheet to place the chart in. In this case, we will use Sheet2.
As soon as you are ready, click the OK button to move the chart.

Now, the chart has been embedded as an object into the worksheet.

To remove a chart from your worksheet, click in the chart area, and press the Backspace or Delete key on your keyboard.

**Enhancing a Chart with Shapes and Graphics**

There are times when you may want to add additional graphic elements to a chart, such as arrows or callouts, to point out and explain important features.
In a chart like the following, you may want to point out that cone number 4 shows the greatest percentage of profits.

To add a callout to the chart, click the lowest down pointing arrow beside the Shapes group on the Insert Tab.
This action will display a large menu of preset shape options.
Find and select a callout from the bottom of the shapes menu, and then draw it out by dragging with the mouse over the chart. (For our purposes, we’ll use the cloud callout.)

You can enter text into the callout by right clicking on it and selecting Edit Text from the drop down menu.

You can use this procedure to add as many shapes or graphic elements to your chart as you think are necessary.
Lesson 1.2: Working with Charts, Part 2

This lesson will expand on the concepts covered in the previous lesson. In this lesson you will learn how to apply a new chart type to your source data and how to change the source data while maintaining the same chart type. You will also learn how to create chart templates and how to work with the chart axis and data series.

Changing the Type of Chart

What do you do if you create a chart based on your spreadsheet data and you find that it just isn’t quite what you were hoping for? If you are using Excel 2007, it is a quick and simple matter to apply a new chart type to your data.

To change the chart type, first display the Design tab by clicking on the chart area and then click the Design tab. Now, look for the Change Chart Type button.

If you click this button, you will display the Change Chart Type dialog box.
With this box, you can select a new chart type or variation based on the data in the existing chart. For example, to change this chart to a clustered pyramid column chart, simply select Column from the panel on the left, and then click the clustered pyramid chart type from the column chart options that are displayed. After you make your choices, click the OK button to change the chart type.

Your chart will be automatically changed according to the selections you make.
Here is an example of the new chart type.

You can also display the Change Chart Type dialog box by right clicking on the chart area and selecting Change Chart Type from the drop down menu that appears.
Changing the Source Data

As you have just seen, Excel 2007 makes it easy to change the chart type for a given set of chart data. The great thing is that Excel 2007 also makes it easy to change the source data for your chart while retaining the original chart type.

In this example, the pie chart above is based on sales data per region. If you wanted the chart to depict Expenses per Region, you would have to change the source data of the chart from the sales data (cells B2 through B5), to the expenses data (cells D2 through D5).

The first step in doing this is to right click on the chart area and click Select Data from the menu that appears.
This action will display the Edit Data dialog box.

At the top of the dialog box, you will see a long text field labeled Chart Data Range. This will show the range of cells that serve as the current data source for the chart. To change the data source, use your mouse to select the new data range from the spreadsheet. As you do this, you will see the new range entered into the data source field.
When you complete your data selection, you will see the new data range in the Edit Data Source dialog box.

![Select Data Source dialog box](image)

The next step is to click the OK button in the lower right of the box. Now, you can see that the size of the pie slices have changed to reflect the new data.
You may notice that now, having changed the source data, the title of the chart (Sales) is not accurate. To change the title, right click on it and select the Edit Text option from the drop down menu. You can now edit the text to change the title to whatever you wish. (In this case, the appropriate title choice is Expenses.)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Region</td>
<td>Sales</td>
<td>Profits</td>
<td>Expenses</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>North</td>
<td>$100,000.00</td>
<td>$25,000.00</td>
<td>$5,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>South</td>
<td>$150,000.00</td>
<td>$32,000.00</td>
<td>$200.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>East</td>
<td>$68,000.00</td>
<td>$12,000.00</td>
<td>$12,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>West</td>
<td>$176,000.00</td>
<td>$50,000.00</td>
<td>$1,500.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Keep in mind that if you enter new data directly into the spreadsheet cells that serve as the data source for the chart, the chart itself will be updated automatically to represent the changes. You do not have to do anything special to update direct modifications to the source data cells.

**Working with the Chart Axis and Data Series**

In a typical chart, the axes are the horizontal and vertical scales that you use to coordinate your data. Basically, data is charted with respect to its numerical position along an axis.

A series is a group of data (normally a selection of cells) that is to be charted against an axis. You can have more than one series represented in a chart to show how the different series (selections of data) compare to each other.

To add more than one series to a chart, right click on the chart and click Select Data from the menu that appears.
This will display the Edit Data dialog box. In this dialog box you will see buttons for adding and removing a series.

To add a new series to the chart click the Add button. This will display an Edit Series box where you can enter a name for the series in the name field that is provided.

Next, you can enter a range of data for the series by dragging your mouse pointer to select a range from your spreadsheet. (In this example, we are adding the sales data to a column graph that shows expense data.) You can enter data sources and series by typing a range directly into its field in a dialog box, but selecting with the mouse is usually simpler.

After you select the appropriate data, click the OK button on the Edit Series dialog and then on the Edit Data Source dialog.
Here you can see that two series (Expenses and Sales) are represented in the chart.

If you display the Edit Data Series dialog, you will see two names in the series section of the dialog box.

You can select either one of these series and click Remove to remove it from the chart. You can also click the Add button to add even more data series to the chart if you wish.
In the following stacked line chart, the Sales data and Profit data are represented against a Y axis consisting of dollar amounts.

If you right click on one of the dollar amounts on the Y axis, you will display a drop down menu. From this menu, you can choose a Format Axis option.
This will display a Format Axis dialog box.

In this box, you will find controls to specify the units and adjust the scale, tick mark, and position of the Axis labels.

If you select a different heading from the panel on the left of the box (the heading highlighted in this image is Axis Options) you can change the line style of the axis, the shadow, and other aspects of its format.
If you want to change the labels on an axis, invoke the Select Data dialog box.

You can see an edit button in the Axis Labels area (on the left) of the dialog box. If you click the Edit button, an Axis Labels box will appear, and you will be able to select the labels you want from the spreadsheet. Just drag your mouse to select the appropriate cells or manually type the cell range into the box provided.
Here is the same chart that was shown previously, with its axis and labels changed.

A more convenient way to quickly select a chart layout is to use the Chart Layouts available on the Design tab.

With these buttons, you can quickly apply numerous layouts to your chart by clicking. You can also use the scroll bar at the right of the group to view more layout types.
Here are a couple of different layouts for the chart. Both were chosen with the chart layout buttons.
Saving a Chart as a Template

Once you get your chart looking just the way you like it, you can save the chart type, colors, and formatting as a template that can be reused to make on future charts.

Assume that this image represents a chart style and format that we are happy with and that we would like to use in the future.

To save this chart as a template, display the Design tab by clicking on the chart area. On the Design tab, click the Save as Template button.

This will display a Save Chart Template dialog box; it’s virtually identical to the regular Save dialog. Just enter an appropriate name for your chart template and then click the Save button. By default, the templates will be saved in an Excel chart folder.

When you want to use the template, just select a data range for the new chart from whatever spreadsheet you are working on and then click the small arrow at the lower right of the Charts group.
This will display the Create Chart dialog box.

If you select Templates in the pane on the left of the box, you will see the chart template that you saved displayed on the right side. Just click the template icon to apply the template to the selected data.
Section 2: Getting the Most From Your Data

In this section you will learn how to:

- Use automatic outlining
- Display and collapse levels
- Group data manually
- Create subtotals
- Create a PivotTable
- Specify data in a PivotTable
- Rearrange PivotTable data
- Modify PivotTable calculations
- Format a PivotTable
- Refresh a PivotTable
- Chart a PivotTable
- Create a PivotTable based on external data
- Create a scenario
- Create a scenario summary report
- Save multiple scenarios
- Use a one and two input data table
- Use Goal Seek
- Use the solver
Lesson 2.1: Getting the Most from Your Data

Sometimes, a worksheet can become so large and contain so much data that it becomes unwieldy. Totals and subtotals that summarize the data are lost in screen after screen of numbers. Thankfully, Excel 2007 has an excellent feature to help with this kind of problem.

Excel’s grouping and outlining features will allow you to collapse a large worksheet to show or print summary data, and to expand the same worksheet to show or modify the details. You will find these features in the Outline button group on the Data tab.

Using Automatic Outlining

Excel’s automatic outlining feature makes outlining a worksheet fairly straightforward. Automatic outlining works best with numerical data organized into groups and sub groups by formulas or functions. The following worksheet, for example, contains monthly financial data for a business, organized into quarterly and yearly totals using formulas and the SUM function.
It can be difficult to discern quarterly and yearly totals at a glance because these figures are lost in amongst the other data.

To automatically outline this worksheet, click the small arrow next to the Group button in the Outline button group on the Data tab.

This action will display a menu with two options: Group and Auto Outline. If you click the Auto Outline button, the spreadsheet will be outlined automatically.

Here you can see the results of Excel's automatic outline. All of the original data is shown, as well as outline grouping indicators and collapse buttons marked with a (-). You can see that the quarters (sets of three months) are grouped together to be summarized by Quarterly Totals, and that each year has been grouped to be summarized by Yearly Totals.
Notice also that the columns Supplies, Wages, and Rent have been grouped under Total Expenses, and that there is an overarching group of all columns under Profit.

Here you can see the summary results of Excel’s automatic outline. The original information is still available in all of its detail, but it is now presented in a summary view, showing only the yearly profit totals. Of course, automatic outlines will differ from worksheet to worksheet depending on the way the data is organized.

To remove the outlining from your worksheet, choose the Clear Outline option from the submenu under the Ungroup button.

**Displaying and Collapsing Levels**

Notice that in the preceding outline image, there are numbered buttons arranged in a row beside the column letters and in a column above the row numbers. Clicking on one of these numbered buttons arranged in a row will expand the rows in the worksheet to provide a given level of detail. Clicking on one of the numbered buttons arranged in a column will expand the columns in a similar way.

The view of the data in the preceding image is provided by the buttons numbered 1.
Clicking on the number 2 button will expand the worksheet to the second level of detail for the rows, columns, or both.

This is the same worksheet after both number 2 buttons have been clicked. The worksheet rows and column have been expanded to show another level of detail. You can now see rows with quarterly totals as well as yearly totals. You can also see columns with figures for Sales and total Expenses.

If you click on an expand button (marked with a + sign), a specific section of the outlined worksheet corresponding to the button will be shown. Clicking the collapse (-) button will collapse the corresponding expanded section.

If you click the number 3 button for the rows and columns, all levels of detail will be expanded to expose all of the data, as shown in the original image.

Remember that with outlines, only the data that is visible on your screen will be printed. This is a great way to print only the pertinent information from an expansive worksheet. You can expand and collapse the outlined worksheet with the numbered outline buttons or with the
expansion (+) and collapse (-) buttons to reveal the level of detail you want in your printed copy.

**Grouping Data Manually**

Automatic outlining may not be adequate for worksheets with non numerical values or with no distinctive totals (from formulas or functions).

If automatic outlining does not, or cannot, organize your data in the way you want, you can manually group your data as required. Take the following worksheet as an example.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>1st Division</td>
<td>Wins</td>
<td>Losses</td>
<td>Ties</td>
<td>Points</td>
<td>Rank</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Rockets</td>
<td>2</td>
<td>2</td>
<td>1</td>
<td></td>
<td>Second</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>Joe</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>20</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>Jake</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>23</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>Linda</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>22</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>Jets</td>
<td>1</td>
<td>3</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>Tim</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>12</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>Frank</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>11</td>
</tr>
<tr>
<td>10</td>
<td>2nd Division</td>
<td>Walter</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>13</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>Tigers</td>
<td>3</td>
<td>2</td>
<td>0</td>
<td></td>
<td>First</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>Nancy</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>23</td>
</tr>
<tr>
<td>13</td>
<td></td>
<td>Lisa</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>23</td>
</tr>
<tr>
<td>14</td>
<td></td>
<td>Jessica</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>14</td>
</tr>
<tr>
<td>16</td>
<td></td>
<td>Pirates</td>
<td>1</td>
<td>4</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td>Bob</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>33</td>
</tr>
<tr>
<td>18</td>
<td></td>
<td>Sandra</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>35</td>
</tr>
<tr>
<td>19</td>
<td></td>
<td>Ellen</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>25</td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

We would like to group the data according to teams and divisions, but if you use the Auto Outline option under the Group button, Excel displays the following alert.
Because the data contains no formulas or functions providing numeric totals, Excel cannot implement automatic outlining for the worksheet. You can, however, create your own groupings by selecting the rows or columns that you want to group, and then clicking the Group button.

For example, if you select the members of Team 1 (cells B4:B6) and click the Group button on the Data tab, Excel will display the following box asking if you want to group by rows or columns.

If you select the Rows radio button and click OK, Excel will provide an outline indicator and a collapse/expand button for the new grouping.

You should also notice numbered buttons in the top left corner. These outline level buttons work the same as before. Clicking on the number 1 button will show the first level of detail, and clicking on the 2 button will show the second, more detailed level.
If you follow the same procedure for cells B8:B10, and then select cells B2:B10 and group them, you will end up with a worksheet like this.

![Worksheet Image]

This image shown above is of the fully detailed view. If you click the 2 button, you will see the following view of the data.

![Detailed View Image]

You can see that the individual player information for the first two teams has been collapsed from view.
Clicking the number 1 button will display the highest level view (lowest detail) of the manual groupings.

In this image you can see that the entire first division grouping has been collapsed from view.

You can also select rows or columns for grouping by dragging your mouse over the column letters or row numbers accordingly. If you select the rows or columns this way, you will not be asked whether to group by rows or columns, as the selection you choose will clearly indicate this to Excel.

To remove manual groupings, select the rows or columns corresponding to the grouping you wish to remove and click the Ungroup button.

When you see the Ungroup dialog box, select the appropriate radio button, and click OK. The selected rows or columns will be ungrouped.

**Creating Subtotals**

Another kind of outlining or grouping technique available in Excel is the subtotals feature. If you have numeric data organized with clear column and row headings, you can use Excel to create automatic subtotals and grand totals for the data.
The following worksheet contains sales information for different products across geographical regions.

![Excel Worksheet]

To use Excel’s subtotal feature, select the range of data you want to apply subtotals to and click the Subtotal button on the Data tab. Be sure to include the column labels in your selection so Excel will be able to discern what numbers to total. For this example, you could select A1:E10 and click the Subtotal button on the Data tab to invoke the following Subtotal dialog.

![Subtotal Dialog]

The drop list under the “At each change in” heading gives you options as to the number of rows that will be totaled. (Totals will be applied every time the values under the chosen column label changes.)
The “Use function” drop list lets you choose from a list of functions including SUM, AVERAGE, COUNT, PRODUCT, and STDEV to apply to your data. The function you choose (normally SUM) will be used to calculate the totals.

Under the “Add subtotals to” option list, you can select which columns to apply the totals to. You can apply totals to a single column or to multiple columns in the selected range.

Finally, there are three check boxes at the bottom of the dialog box that will allow you to:

- Replace any pre-existing subtotals
- Put page breaks between totaled groups so they will be printed on separate pages
- Place the subtotals and grand totals above or below the corresponding data

If you choose to apply totals to each change in the region column while using the Sum function for the profit column, and with no page breaks, the resulting worksheet will look like this.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Region</td>
<td>Product</td>
<td>Units sold</td>
<td>Price per unit</td>
<td>Profit</td>
</tr>
<tr>
<td>2</td>
<td>East</td>
<td>TypeA</td>
<td>23</td>
<td>$2,000.00</td>
<td>$46,000.00</td>
</tr>
<tr>
<td>3</td>
<td>East</td>
<td>TypeB</td>
<td>7</td>
<td>$1,500.00</td>
<td>$10,500.00</td>
</tr>
<tr>
<td>4</td>
<td>East</td>
<td>TypeC</td>
<td>13</td>
<td>$2,350.00</td>
<td>$30,550.00</td>
</tr>
<tr>
<td>5</td>
<td>East Total</td>
<td></td>
<td></td>
<td></td>
<td>$87,050.00</td>
</tr>
<tr>
<td>6</td>
<td>West</td>
<td>TypeD</td>
<td>12</td>
<td>$4,000.00</td>
<td>$48,000.00</td>
</tr>
<tr>
<td>7</td>
<td>West</td>
<td>TypeC</td>
<td>12</td>
<td>$2,350.00</td>
<td>$28,200.00</td>
</tr>
<tr>
<td>8</td>
<td>West</td>
<td>TypeA</td>
<td>12</td>
<td>$2,000.00</td>
<td>$24,000.00</td>
</tr>
<tr>
<td>9</td>
<td>West Total</td>
<td></td>
<td></td>
<td></td>
<td>$100,200.00</td>
</tr>
<tr>
<td>10</td>
<td>South</td>
<td>TypeE</td>
<td>12</td>
<td>$5,450.00</td>
<td>$65,400.00</td>
</tr>
<tr>
<td>11</td>
<td>South</td>
<td>TypeC</td>
<td>10</td>
<td>$2,350.00</td>
<td>$23,500.00</td>
</tr>
<tr>
<td>12</td>
<td>South</td>
<td>TypeB</td>
<td>8</td>
<td>$1,500.00</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>13</td>
<td>South Total</td>
<td></td>
<td></td>
<td></td>
<td>$100,900.00</td>
</tr>
<tr>
<td>14</td>
<td>Grand Total</td>
<td></td>
<td></td>
<td></td>
<td>$288,150.00</td>
</tr>
</tbody>
</table>

Notice that there is a subtotal for the profit figures at every change in the region value. There is also a grand total for the Profit column at the end of the data. You can also that Excel has provided outlined levels, collapse/expand buttons, and numbered outline level buttons associated with the totals. These buttons and outlines work exactly as previously explained. The lower the number on the button, the less detailed information will be shown.
To remove these subtotals, select the range of data in question (A1:E14) and click the Subtotal button to invoke the subtotal dialog box. When you see the box, click the Remove All button.
Lesson 2.2: PivotTables

A major function of any spreadsheet program is to help you derive meaning from your data. An Excel PivotTable is a great tool for getting perspective on, and analyzing relationships between, the columns and rows of your worksheet.

In this lesson you will learn what a PivotTable is and how to create one. You will also learn how to specify and rearrange PivotTable data. Finally, in the Step by Step exercise, you will practice creating a PivotTable.

What is a PivotTable?

A PivotTable is a powerful tool for exploring and analyzing information. A PivotTable helps you organize and manipulate the raw data in your spreadsheet, giving you insight into patterns or relationships that might not be obvious at first glance. PivotTables also give you the power to view your data in a different context without changing the original content or structure.

You can base a PivotTable on data in your current workbook or even external data from another source if you wish. With a PivotTable, you can conveniently drag and drop columns of your data to different areas of the table to examine relationships or trends that may not be obvious in a traditional Excel table or database. You could build several separate tables to explore how columns from an Excel worksheet relate to each other, or you can use one PivotTable to do the same thing. With a PivotTable, you can alter the table design without
cutting, copying, pasting, or adjusting formulas and cell references. (These tasks can be frustrating when dealing with a large volume of data.) In short, PivotTables enable you to organize your data in meaningful ways without doing a lot of tedious work. You could say that a PivotTable is like several data tables rolled into one.

Ideally, source data for a PivotTable should be structured like a traditional Excel table or database. The source data should have a row of unique column headings distinguishing the data and there should be no empty columns interspersed within the data. Also, blank rows in a source list or database can limit the usefulness of your PivotTable.

The following image shows a block of contiguous data that is well suited for a PivotTable.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Month</td>
<td>Salesman</td>
<td>Region</td>
<td>Profit Table</td>
<td>Sales</td>
<td>Profit</td>
</tr>
<tr>
<td>4</td>
<td>Month 1</td>
<td>A.Smith</td>
<td>Northeast</td>
<td>Type 1</td>
<td>100</td>
<td>$200.00</td>
</tr>
<tr>
<td>5</td>
<td>Month 1</td>
<td>J.Adams</td>
<td>Southwest</td>
<td>Type 2</td>
<td>250</td>
<td>$500.00</td>
</tr>
<tr>
<td>6</td>
<td>Month 1</td>
<td>B.Doe</td>
<td>North</td>
<td>Type 3</td>
<td>300</td>
<td>$600.00</td>
</tr>
<tr>
<td>7</td>
<td>Month 1</td>
<td>M.Parker</td>
<td>Midwest</td>
<td>Type 4</td>
<td>400</td>
<td>$800.00</td>
</tr>
<tr>
<td>8</td>
<td>Month 1</td>
<td>A.Smith</td>
<td>East</td>
<td>Type 5</td>
<td>300</td>
<td>$600.00</td>
</tr>
<tr>
<td>9</td>
<td>Month 1</td>
<td>J.Adams</td>
<td>West</td>
<td>Type 6</td>
<td>525</td>
<td>$1,050.00</td>
</tr>
<tr>
<td>10</td>
<td>Month 2</td>
<td>A.Smith</td>
<td>Northeast</td>
<td>Type 1</td>
<td>200</td>
<td>$400.00</td>
</tr>
<tr>
<td>11</td>
<td>Month 2</td>
<td>J.Adams</td>
<td>Southwest</td>
<td>Type 2</td>
<td>250</td>
<td>$500.00</td>
</tr>
<tr>
<td>12</td>
<td>Month 2</td>
<td>B.Doe</td>
<td>North</td>
<td>Type 3</td>
<td>300</td>
<td>$600.00</td>
</tr>
<tr>
<td>13</td>
<td>Month 2</td>
<td>M.Parker</td>
<td>Midwest</td>
<td>Type 4</td>
<td>400</td>
<td>$800.00</td>
</tr>
<tr>
<td>14</td>
<td>Month 2</td>
<td>M.Parker</td>
<td>East</td>
<td>Type 5</td>
<td>450</td>
<td>$900.00</td>
</tr>
<tr>
<td>15</td>
<td>Month 2</td>
<td>B.Doe</td>
<td>West</td>
<td>Type 6</td>
<td>500</td>
<td>$1,000.00</td>
</tr>
<tr>
<td>16</td>
<td>Month 3</td>
<td>B.Doe</td>
<td>Northeast</td>
<td>Type 1</td>
<td>100</td>
<td>$200.00</td>
</tr>
<tr>
<td>17</td>
<td>Month 3</td>
<td>J.Adams</td>
<td>Southwest</td>
<td>Type 2</td>
<td>700</td>
<td>$1,400.00</td>
</tr>
</tbody>
</table>

Notice that there are no empty rows or columns and that every column of data has a unique label.

**Creating a PivotTable**

To create an Excel 2007 PivotTable, just select the range of data that you want to base the table on and then click the PivotTable button on the Insert tab to display the PivotTable dialog.
When the Create PivotTable dialog box appears, you should notice that you are allowed to select data from an Excel table or range or from an external data source. If you choose the table or range option, the PivotTable will be based on the Excel table or range you select.

You can select a table or range by dragging with your mouse before clicking the PivotTable button (before you invoke the dialog), or by specifying a range with the keyboard or mouse after you invoke the dialog. (When you select your data source, make sure that the column headings are included.)

If you choose the External Data Source option, you can base your PivotTable on data outside your current workbook (such as another workbook or perhaps an external database). If you select the Use an External Data Source radio button, you will be able to display a drop list of existing connections in the Connection Name field. A typical existing connection could be a Microsoft Query or a connection you previously made to an Access database for some other purpose.

Once you select your data source, you can then choose to locate your PivotTable in an Existing Worksheet or a New Worksheet. If you choose to locate it in an existing worksheet, you can specify the location for the upper left corner of the PivotTable by entering it directly into the Location data field (as a cell reference) or by clicking the target cell with your mouse.

If you choose the new worksheet option, your PivotTable will be located in the upper left corner of a new worksheet that will be added to your workbook.

In summary, when using the dialog box, make sure that the range of data that you want to use is visible in the Table/Range field. Use the radio buttons near the bottom of the dialog to choose where in the workbook you want the PivotTable to be located. Once you are ready, click
the OK button to create your PivotTable. When you create your table, a PivotTable field List will be placed in the same worksheet as your PivotTable.

Here you can see a new PivotTable area, and the corresponding PivotTable field List, placed in the existing worksheet with the source data.

Once your PivotTable appears, you can add information to it by placing checks in the boxes next to the headings in the PivotTable field list.
For this example, checks will be placed next to the Month field heading, the Salesman field heading, the Region field heading, and the Profit field heading.

The PivotTable will now be populated with data.

As you can see in this image, the profit has been organized by Month with a total profit for the month at the top of the Sum of Profit column heading. It has also been organized by Salesman, with a total profit for each Salesman being shown in the Sum of Profit column. Because Region has been checked in the PivotTable field list, you can also see a profit breakdown by region for each salesman.
The following “close up” view of the table tells us that the total profit for Month 1 is 4090. The Salesman A. Smith generated a total of 1020 in profit with 780 from the East region, and 240 from the Northeast region.

<table>
<thead>
<tr>
<th>Month 1</th>
<th>4090</th>
</tr>
</thead>
<tbody>
<tr>
<td>A. Smith</td>
<td>1020</td>
</tr>
<tr>
<td>East</td>
<td>780</td>
</tr>
<tr>
<td>Northeast</td>
<td>240</td>
</tr>
<tr>
<td>B. Doe</td>
<td>600</td>
</tr>
<tr>
<td>North</td>
<td>600</td>
</tr>
</tbody>
</table>

The salesman B. Doe generated a total of 600 in profit from the North region. If you click on the minus (-) sign preceding a salesman’s name, the data for that specific salesman will be collapsed, and you will only see the total profit for that person as shown in the following example.

<table>
<thead>
<tr>
<th>Month 1</th>
<th>4090</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ A. Smith</td>
<td>1020</td>
</tr>
<tr>
<td>- B. Doe</td>
<td>600</td>
</tr>
<tr>
<td>North</td>
<td>600</td>
</tr>
</tbody>
</table>

If you click on the (+) sign in front of a name, the data will be expanded again. This holds true for the (-) sign in front of the Month headings as well.

**Creating a PivotTable Frame**

You can also create a PivotTable by creating an empty table frame (also known as a classic layout) and adding and arranging data in the table by dropping and dragging column headings onto the frame.

To create a PivotTable frame, click the PivotTable button on the Insert tab to display the PivotTable dialog box. From this point, you essentially follow the same process as described before for creating an Excel 2007 PivotTable.
You select a range of data, choose a location for the table, and click the OK button when you are ready.

This time, before adding data to the PivotTable table, right click on it and choose Table Options from the pop-up menu.
This will display the PivotTable Options dialog box.

In the options box, choose the Display tab and then put a checkmark in the Classic PivotTable Layout box.
This will change the Excel 2007 PivotTable into a classic PivotTable frame. (If you are already working with a classic PivotTable frame, you can clear this checkbox to convert it to an Excel 2007 style PivotTable.)

Here you can see an empty PivotTable frame enhanced with blue borders. Beside it to the right, you can see the PivotTable Field List. You can easily add any of the data available in the PivotTable Field List to your PivotTable by dragging it to the table with your mouse.

**Specifying PivotTable Data**

To make the best use of your PivotTable, you should understand what the various areas in a PivotTable are for.
You can see by examining an empty PivotTable frame that a PivotTable is broken into four main areas: Page, Data, Row, and Column.

The Page area is ideally suited to column headings (fields) that are used to identify periodic or organizational groupings of the data in your other columns. For example, you may have column headings for sales, profit, and expenses, which are grouped according to the specific month or year over which the sales, profits, and expenses have occurred. In this case, the month or the year column heading would be placed in the page area of the PivotTable. This would allow you to populate the table with the data corresponding to whatever page field (year or month) you select. You can select a given page (year or month) and the table will display the data for that year or month.

The Data area provides the underlying context for the rest of the PivotTable. The column heading you choose for the data area of the table normally has numeric values associated with it (like units sold, profit, or expenses). This is the kind of data that can be measured and totaled to reveal trends or indicate relationships between non numeric data.

The Row and Column fields are used to categorize the data you want to examine. When you choose column headings to be placed in the row and column fields, you can see how your choices relate to each other in the context of the Data being examined.

As an example, suppose you select a heading like Product Type for the row area, Salesman for the column area, and Profit for the data area.
The resulting PivotTable will show the profit for different product types across sales people.

```
<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Sum of Profit</td>
<td>Salesman</td>
<td>D. Doe</td>
<td>J. Adams</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>Product</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Grand Total</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Example PivotTable:

```

Now that you have an idea of how the parts of a PivotTable relate, it is easy to specify data for the table. You just use your mouse to drag and drop items from the PivotTable field list to the appropriate areas of the table.

Once again, you should specify a column heading (field) that represents numeric values for the data area. For the row and column areas of the table, drag and drop items that you want to analyze with respect to the chosen item for the data area.

You can drag and drop more than one column heading to a table area. The resulting table will display the combined data from all of the headings you place in a single table area, as shown below.
Here, both the product type heading and the salesman heading have been dragged to the row area of the table. You can now see the sales by salesman and product type displayed across regions.

You will notice that the PivotTable field list at the right of your PivotTable will have checkmarks corresponding to the column headings used in the table itself.

If you clear a checkbox, the associated data will be removed from the PivotTable. If you put a check in a checkbox that was cleared, the data will return to its place in the table.

**Rearranging PivotTable Data**

Once a PivotTable has been created, it is easy to rearrange the data if necessary. Note that you must be using the Classic Layout (as described in the last lesson) to rearrange data.

Here we have a table showing profit by product type across regions.
If we wanted to show sales figures instead of profit figures, you can remove the profit information from the data area by dragging the Sum of Profit heading in the upper left corner of the table out of the table area to drop it anywhere outside the blue table borders.

This will empty the data area.

Once the data area has been cleared, it is just a matter of dragging and dropping the Sales field from the PivotTable Field List to the Drop Data Items Here area of the table.
In this image, the Sales heading is being dragged from the field list to the Data area of the table. Once the move is complete, this is what the table will look like:

![Table with Sales data](image)

Notice that Sum of Sales is in the upper left corner and the Sales heading has a check next to it in the PivotTable field list.

You can rearrange any of the categories of data in your table by following this process of dragging headings out of the table and then replacing them with headings from the PivotTable field list.

You will also notice that the row, column, and page areas of the PivotTable field list have drop lists associated with them, indicated by small downward pointing triangles.

![Drop lists](image)

You can use these drop lists to rearrange your data according to specific elements in a given category.
The product drop list, for example, will let you see data for only Type 1, or Type 2, or for a specific combination of types, depending on how you configure the check boxes.

This is the drop list for the Product heading. (Any of the headings in the PivotTable that have drop lists can be configured in the same way.)

This table only shows data for the products of Type 1 and Type 2, as specified by in the Product drop list. (By default, the drop lists are configured to show all.)

In the following image, the Month field has been dragged to the Page area of the table. The drop list for the Month field can be used to show the data for a specific month, or all of the months.
As you now know, you can specify and rearrange data by dragging headings from the PivotTable Field List to the PivotTable itself.

If you close the PivotTable Field List, you can always get it back by clicking the Field List button on the Options Tab.

The Options tab and the Design tab will become available whenever you click inside the borders of your PivotTable.

The previous discussion has dealt primarily with PivotTable frames, also known as classic PivotTable layouts. Now you will learn how to arrange data in the default Excel 2007 PivotTable layout.

You will remember from the earlier discussion that when you create a standard PivotTable in Excel 2007, it looks like this:

Here you can see the empty PivotTable on the left and the PivotTable field List on the right.
At the bottom of the PivotTable field list, you will notice a panel of four data boxes.

These boxes are named Report Filter, Column Labels, Row Labels, and \( \Sigma \) Values. They correspond to the Page fields, the Column fields, the Row fields, and the Data Item areas of a classic PivotTable frame.

Dragging an item from the PivotTable field list to the \( \Sigma \) Values data box produces similar results as dragging the item to the Data items area of a classic PivotTable frame. This holds true for the other data boxes as well.

As an example, if we drag Month from the field list to the Report filter box, Region from the field list to the Column Labels box, Product from the field list to the Row Labels box, and Sales from the field list to the \( \Sigma \) Values box, our resulting PivotTable will look like the following.
The corresponding panel of data boxes will look like this.

![PivotTable Panel]

You can easily drag field headings to and from the data boxes in the panel to rearrange the layout of the PivotTable.

![Classic PivotTable]

Here is a classic PivotTable showing profit per product, across regions. Notice that the classic table has thick blue borders.
Lesson 2.3: More About PivotTables

The previous lesson described how to create a PivotTable and arrange the data in it. This lesson will carry on from Lesson 2.2 and explore other ways to manipulate and present PivotTables and their data.

In this lesson we will discuss how to modify PivotTable calculations, how to format a PivotTable, and how to refresh PivotTable data. You will also learn how to create a chart from a PivotTable and how to create a PivotTable using external data. In the exercise, you will add data to a PivotTable, format the PivotTable Data, change PivotTable calculations, and create a chart from the PivotTable.
Modifying PivotTable Calculations

The default setting for PivotTable calculations is SUM. This means that the totals shown in the Grand Total areas of the PivotTable will be derived from summing the values in the rows and columns.

To modify the way these totals are calculated, right click on the Sum of Profit field in the upper left corner of the PivotTable. This field represents the data area of the PivotTable (you could also right click on any cell in the data area of the PivotTable). When you right click on a cell in the data area or on the cell in the upper left (Sum of Profit), you will see a pop-up menu with several options.

Near the bottom of the menu (third from the bottom in this image), you will see an option called Value Field Settings.
If you click on this option, you will display the PivotTable Data Field Settings dialog box.

In this dialog box, you can switch the type of calculation to Count, Average, Max or Min, Product, Standard deviation, or Variance. For this example, Average has been selected.

If you click the Number button, you can choose a format like currency, accounting, or text for the values in the data area of the table.

Under the Show Values As button, you can modify the data area values further by expressing them as percentages or differences.

Clicking OK will incorporate the changes into the PivotTable.

Here you can see that the data field label in the upper left of the PivotTable now says Average of Profit, and the values in the grand total row and column are averages rather than sums. You can modify any field that you place in the data area of the table in this same way.
Formatting a PivotTable

To format a PivotTable, first click on any cell in the table to display the Options tab near the top of your Excel screen.

At the left of the Options Tab, in the PivotTable button group, you will find an Options button. Clicking this button will display the PivotTable Options dialog box.

Under the Layout and Format tab, make sure the “Preserve cell formatting on update” box is checked (it should be by default). This will ensure that any formatting you apply will be retained if the table is modified or refreshed.
Under the Totals and Filters tab, you can specify if grand totals for rows or columns will be shown.

Under the Display tab, you can configure how filter drop downs, field captions, expand/collapse buttons, and contextual tool tips are shown.

Under the Printing tab you can alter the layout of a PivotTable printout. Finally, under the Data tab you can specify PivotTable data options, like having the table refreshed when the workbook opens.

Click OK when you are finished with the PivotTable options dialog.

In Excel 2007, the easiest way to format your PivotTable is to use the new PivotTable Styles that are provided on the Design tab. When you click on a cell in your PivotTable, an Options tab and a Design tab will appear near the top of the Excel screen.

On the Design tab, you can click on one of the preset styles in the PivotTable Styles group to quickly apply preset formatting to the table. There are also checkboxes in the PivotTable Style Options section of the tab that will let you specify banded columns or rows, row headers, or column headers. At the left of the tab are controls that you can use to view or hide subtotals and grand totals and to specify a PivotTable report layout type.

Here is a style with banded rows applied to an existing PivotTable.

If you would like to apply specific formatting to a table that is not available as a style, you can always select a range of cells from the table and use the buttons on the Home tab to format the
selected range. Another method is to select a range of cells from the table, right click in the selected range, and choose Format Cells from the drop down menu. You can then choose from a series of tabs in the format cells dialog box that will let you select number formats, font styles, borders, and protection options.

You can also right click a cell in the data area of the table and select the Value Field Settings option from the pop-up menu.
When you see the Data Field Settings dialog box, click the Number Format button to view the number formatting options.

Here, you can select a number format from the list and click OK to return to the Data field settings dialog box. Click OK again to format the entire data area of the PivotTable with the chosen number format.
The previous image shows a PivotTable with the Accounting number format applied to the data area. Notice also that the words North and Northeast in the column area of the table have been formatted in bold by using the Home tab buttons.

**Refreshing a PivotTable**

The data in a PivotTable is not linked directly to the source table or range. Instead, the PivotTable is based on a hidden copy of the source data that is kept in memory by Excel. This means that changes to the original source list or database will not be automatically updated in the PivotTable. If you make changes in the source data, you must refresh the PivotTable to update it.

You can refresh a PivotTable by clicking the Refresh button on the Data tab or on the Options Tab. You could also right click on a cell in the data area of the table and then click the Refresh Data option from the pop-up menu.

Here is a range of data and a PivotTable that uses the data range as its source.

If we change the sales for A Smith in the East, (in the source data range), there will be no change in the PivotTable. (The data in cell E8 has been changed to 20000 and the corresponding profit in cell F8 is now 40000.)
Here is the same data and PivotTable after the PivotTable has been refreshed. Notice that cell I4 now has a value of 40500.

Charting a PivotTable

In Excel 2007, you can create a PivotChart from scratch, or you can create a PivotChart based on an existing PivotTable. To create a chart based on an existing PivotTable, simply click a cell in the table and then click on a chart type from the Charts area on the Insert tab.

In the image above, a basic column chart has been selected and created from an existing PivotTable. This particular chart shows profits generated by each salesman broken down over regions. Any changes or rearranging of field values in the PivotTable will be automatically
reflected in the PivotChart. If there are changes made to the source data for the PivotTable, any of the refresh options previously mentioned will update both the PivotTable and the PivotChart. This makes the PivotChart every bit as malleable as the PivotTable upon which it is based.

If a basic column chart is not what you are after, you can select any other chart type from the Insert tab except XY Scatter, Bubble, or Stock charts. Once you create your chart, you can click on your chart area and then display the Design tab which will allow you to apply a preset format to your chart via the chart styles buttons.

Keep in mind that all chart types may not be equally suited for displaying your PivotTable data. Pick the chart type that most clearly illustrates the point you want to put forward.

Here is the same PivotTable data as before, but now it is displayed as a three dimensional bar chart. Again, changes to the source data will be reflected in the PivotTable/Chart after it has been refreshed.

You can also create a PivotTable/PivotChart combination from scratch by choosing the PivotChart option from the PivotTable button’s pop-up menu.
Remember, the PivotTable button is located on the Insert tab.

When you click the PivotChart option in the PivotTable button menu, you will see the following PivotTable with PivotChart dialog box.

In this dialog, click in the Table/Range field to place a cursor inside and then select the range of cells that you want to use from the spreadsheet. You can also select the range before invoking the dialog if you wish. Once the range or table has been selected, you can choose to place the new table/chart on a new worksheet, or on the existing worksheet, by selecting the appropriate radio button. In the image above, the New Worksheet option has been selected.
As soon as you are ready, click the OK button to create the new PivotTable/PivotChart combination.
If you wish, you can right-click on the PivotTable area, select the PivotTable Options item from the pop-up menu, and then choose the Display tab and check the Classic PivotTable Layout option to create a classic frame.

Here you can see a classic PivotTable frame, empty PivotChart, and PivotTable field list.

Your PivotChart will first appear empty, very much like your basic empty PivotTable. When you drag field headings from the PivotTable field list over to your Table frame, the data from the fields will also begin to populate the chart. In a sense, the layout that you create for the actual PivotTable will be mirrored automatically in the PivotChart.
If you prefer to build your PivotTable without switching to the classic layout, the chart will be created automatically as you drag your field headings to the panel of data boxes at the bottom of the PivotTable field list.
Here is the chart and PivotTable after dragging field headings from the PivotTable field list to the appropriate table locations. You can easily format the PivotChart by clicking on the chart area, and then using the Styles on the Design tab to choose a preset design.

(Note the new tabs available for formatting and editing PivotCharts.)
Creating a PivotTable Based on External Data

When you first invoke the Create PivotTable dialog box, you can select the Use an External Data Source radio button.

When you do this, you will be able to select from a list of existing connections (if there are any) to use as a data source. (If there are no existing connections, you will see the Choose Connection button as shown in the figure above.)
When you select an item from the list and click OK, you will see the PivotTable area and PivotTable field list arrangement as before, the difference being that now the field headings in the PivotTable field list will be from the external data source that you selected.

You can now drag and drop the field headings into the panel of data boxes to build your table.
Depending on the external data source you choose, it is possible that you may have to enter a user name/password combination to get access to the data (as shown below).

Once you have entered the appropriate information in the fields provided, click the OK button to begin creating your PivotTable.
You can also click on the Existing Connections button in the Data tab and then select a data source from the dialog box that appears.
Once you select one of the data source connections, click the Open button in the lower right to reveal the Import Data panel.

Once you see this panel of controls, you can specify a Table, a PivotTable Report, or a PivotChart and PivotTable report, for your imported data. You can also specify a new or existing worksheet for your PivotTable location. Once you are finished making your selections, click the OK button to create your PivotTable frame and PivotTable field list.

If you do not have any existing connections, you can create a new one as long as you have access to an external data source. To create a new connection, use the From Other Sources button on the Data tab.
You can create a connection to an SQL server, an Analysis Services cube, or with Microsoft Query if you wish. (See Excel Intermediate manual, lesson 5.5). Once you have created a connection to an external data source, you can proceed to create your PivotTable by following the same procedure used for an existing connection.

You may also remember (from Excel Intermediate lesson 5.4), that you can import data directly from an Access database by using the From Access button on the Data tab.

When you click this button, a Select Data Source dialog box will appear, allowing you to navigate to a given Access database.
When you select a database and click the open button in the lower right of the dialog, you will be presented with the familiar Import Data panel.

Once again, you can use the options in the Import Data panel to specify the type and location of the table you want to build from the imported data.

Here is an Access database table containing the source data.

Here is a classic PivotTable frame and field list created by importing the data from Access.

Once you build a PivotTable using external data, you can refresh the table by clicking the Refresh button on the Data tab.
This will update the PivotTable with any changes made to pertinent data in the source database.

You can also refresh the PivotTable by right clicking a cell in the table and selecting the Refresh option from the pop-up menu.
Lesson 2.4: Exploring Scenarios

In business, it is often beneficial to explore multiple scenarios for a given situation to see what combination of factors gives the best results. With Excel 2007 you can easily explore multiple scenarios based on the same worksheet layout.

In this lesson you will learn what a scenario is and how to create one. You will learn about scenario summary reports and you will learn how to save multiple scenarios for a given situation.

What is a Scenario?

In Excel, a scenario can be described as a set of cell values that is saved and substituted into your worksheet as required. If you have multiple scenarios saved, you can load different scenarios into your worksheet and compare and contrast them to see which one gives the best results. Since the worksheet will be fully calculated according to the given set of scenario data being used, you can compare and contrast the results of one set of data (scenario) with another by simply switching between different scenarios. The end result is that scenarios provide a great way of performing “What if?” analysis.

You might use scenarios to represent different budget options, evaluate different financial forecasts, or to compare different data projections based on a number of factors. The data that makes up your scenario is saved with your workbook, but remains hidden until you use the Scenario Manager to load the scenario data. All of the scenarios you create are just versions of the same worksheet layout, with each different scenario having different values for certain cells.
Creating a Scenario

To create a scenario in Excel, begin with the worksheet that you want to add scenarios to and click the Scenario Manager option from the What–If-Analysis menu on the Data tab.

When you click on this option, the Scenario Manager dialog will appear.
To create a scenario, click the Add button to display the Add Scenario dialog box.

![Add Scenario dialog box]

The Add Scenario dialog is used to specify a name for the given scenario and to enter the cells that will have value changes according to this scenario.

To enter a name, make sure that your cursor is in the Scenario Name text box and type a name that describes the scenario you are creating.

Next, decide which cells you want to change with this scenario, and then put your cursor in the Changing Cells text box. Select the cells that will be changing with your mouse, and remember to use the Ctrl button for non adjacent selections.

If the Add Scenario dialog box gets in the way when you are selecting cells, you can drag it to one side with your mouse, or collapse it by clicking the Collapse Dialog button.

You can also add some remarks describing the scenario in the Comment area of the dialog box if you wish.

You will see two check boxes at the bottom of the add scenario dialog that are labeled Prevent Changes and Hide. If you check the Prevent Changes box, changes to this scenario will not be permitted if the corresponding worksheet is protected. If you check the Hide box, the scenario will be hidden if the corresponding worksheet is protected.
Once you enter a name, select the cells to be changed, and add some comments; click the OK button to show the Scenario Values box.

Here you will see a series of text fields labeled with the cell references for the corresponding changing cells. In each text field, you should enter the appropriate value for this scenario.

When you use this scenario, the values you enter here will be loaded into the corresponding worksheet. Remember, you can move between text boxes by pressing the Tab key.

Click the OK button to create the scenario, and you will then see the Scenario Manager box with your newly created scenario available in the Scenarios area.
In this dialog box, you can see the changing cells in the Changing Cells area and any comments you entered for this scenario are visible in the Comment area. If there is an assortment of scenarios in the Scenario Manager, just select one and then click the Show button to see the results of the given scenario in the spreadsheet.

**Creating a Scenario Summary Report**

To create a summary report for a given Scenario, click the Scenario Manager option under the What-If Analysis button on the data menu.

When the Scenario Manager dialog appears, click the Summary button.
This will display the Scenario Summary box. Here you can choose to create a PivotTable (based on the scenario data) or a scenario summary by selecting the appropriate radio button.

In this example, the Scenario Summary button is selected. The next step is to select the result cells that you want to be shown in the summary report. Finally, click OK to create the summary.

The summary report will be created and inserted into a new worksheet. The report contains a list of cell references corresponding to the changing cells in your various scenarios. It also contains a column of current values for the changing cells, as well as columns of changed values corresponding to each of the available scenarios (Current values, Projection1, Projection2).
There is also a row of scenario names across the top of the columns to identify which scenario a given column of values belongs to. (The scenarios in the report shown above are: Current values, Projection1, and Projection2.) At the bottom of the report, you can see the values for the results cells that correspond to each scenario.

**Saving Multiple Scenarios**

To save multiple scenarios for a worksheet, choose the Scenario Manager option from the What If Analysis menu to display the Scenario Manager dialog. Use the Add button in the Scenario Manager to create as many scenarios as you require. All of the scenarios you create for a given worksheet will be available in the scenarios list in the Scenario Manager dialog.

In this example, you can see four scenarios in the scenario list. These scenarios will be saved with this workbook when the workbook itself is saved. When you open the workbook, you can see the available scenarios by displaying the Scenario Manager.

To load a scenario into the worksheet, select it from the Scenarios list and click the Show button. To remove a scenario, select it and click Delete. To make changes to a scenario, select it and click the Edit button.

You can have a different set of scenarios for each worksheet in your workbook. When you display the Scenario Manager, only scenarios for the currently active worksheet will be shown in the Scenarios list.
Lesson 2.5: What If Analysis

One of the advantages of a spreadsheet program like Excel 2007 is its ability to explore what-if situations. Scenarios (discussed in Lesson 2.4) provide one way to explore the potential outcomes from different sets of possible data, but that is not all that Excel has to offer in this regard.

Excel also provides a few other options for experimenting with your worksheet data under different conditions or constraints. Excel’s one and two input data table features can show you the results of worksheet formulas based on different ranges of hypothetical values. Excel’s Goal Seek and Solver features can take what-if analysis one step further by letting you find optimal values based on constraints or conditions you impose.

In this lesson you will learn about one input and two input data tables, Excel’s Goal Seek feature, and Excel’s solver. In the step by step exercise, you will practice using Goal Seek.

Using a One and Two Input Data Table

You can use Excel data tables to see how your formula results change when the data that the formula is based on changes. You do this by specifying a series of hypothetical values for Excel to evaluate the formulas with and then view the results of the evaluations. For example, you could examine how changes in the number of clients for a business will affect the income or profit.

Data tables save you the trouble of entering several values into the worksheet and recording each recalculation of the worksheet results for later comparison. When you use a data table,
Excel will substitute a range of values into the worksheet formulas for you and tabulate the results so they can be viewed easily.

In Excel, you can create a single input data table or a two input data table. A single input table will substitute a range of values as a single variable in as many formulas as you like. With a two input data table, you can specify ranges for two input variables, but these input variables can only be applied to one formula.

The following example involves a hypothetical consulting firm. Our first goal is to examine the effect of the number of clients for the firm, on the total profit, total expenses, and total income.

Currently, the firm has 10 clients. The values for wages, total client costs, total expenses, and profit are all calculated by formulas dependent on the number of clients the firm can retain. To see what results the profit formula and other formulas would produce for a range of hypothetical client numbers, we can use a single input data table.

There are some rules you should follow when building your data table to help ensure that it works correctly. First, list the values that you want to input into the formulas in a row or column of adjacent cells. For this example, a column of input values is used. In the row just above your input column, enter cell references to the formulas that you want to evaluate. Make sure you enter the references starting one cell to the right of the column of input values.

In the example spreadsheet that follows, the input variables are in the cell range E5:E30. Cell F4 contains the reference =C5, cell G4 contains the reference =C13, and cell H4 contains the reference =C15, for the total income, total expenses, and total profit formulas respectively.
It is a good idea to label your columns appropriately, so you can clearly understand the data table results. In this example, the same labels that appear in the source data are used for the single input data table.

<table>
<thead>
<tr>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Expert Consultants</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Clients</td>
<td>10</td>
<td>Clients</td>
<td>Total Income</td>
<td>Total Expenses</td>
<td>Total Profit</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Fee per client</td>
<td>$ 3,200.00</td>
<td></td>
<td>$ 32,000.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Total Income</td>
<td>$32,000.00</td>
<td></td>
<td></td>
<td></td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Rent</td>
<td>$ 1,500.00</td>
<td></td>
<td></td>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Utilities</td>
<td>$ 700.00</td>
<td></td>
<td></td>
<td>8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Wages</td>
<td>$20,000.00</td>
<td></td>
<td></td>
<td>9</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Other Costs per client</td>
<td>$ 250.00</td>
<td></td>
<td></td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Total Client costs</td>
<td>$ 2,500.00</td>
<td></td>
<td></td>
<td>11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Advertising</td>
<td>$ 6,000.00</td>
<td></td>
<td></td>
<td>12</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Total expenses</td>
<td>$30,950.00</td>
<td></td>
<td></td>
<td>13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>14</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td></td>
<td></td>
<td>$ 1,050.00</td>
<td>15</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>16</td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>17</td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>18</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>19</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>21</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>22</td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>23</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>24</td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>25</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Notice that the formula references (F4:H4) are in a row just above and one cell to the right of the first input variable (E5). The data table is now ready. The input variables are listed in the Clients column and the formula references are one row above and one cell to the right. All of the elements in the data table are clearly identified.
The next step is to select the range of cells from the data table containing the input variables and the formula references. In this example, the range is E4:H30.

Next, choose the data table option from the What-If Analysis menu to display the Data Table dialog box.
The range of input variables and formula references has been selected, and the Data Table dialog box is ready for input.

![Data Table dialog box](image)

Because the input variables are arranged in a column, we will use the “Column input cell” text field in the table dialog box rather than the Row input cell field. In the “Column input cell” text field, enter C3, which is the cell from original data area that contains the number of clients. (Remember that the number of clients is also our chosen input variable.)

Clicking the OK button in the Data Table dialog box will complete the data table.
You can now see at a glance how the 26 different values in the Clients column influence the income, total expenses, and total profit results.
If you change the values in the Client column, the data table will recalculate in accordance with the new values automatically. You can apply formatting styles, borders, shading, and other enhancements to the data table in the same way as you would any other area of your worksheet.

<table>
<thead>
<tr>
<th></th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Expert Consultants</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>Clients</td>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>Fee per client</td>
<td>$ 3,200.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>5</td>
<td>Total income</td>
<td>$ 32,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>Rent</td>
<td>$ 1,500.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>Utilities</td>
<td>$ 700.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>Wages</td>
<td>$ 20,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>Other Costs per client</td>
<td>$ 250.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>11</td>
<td>Total Client costs</td>
<td>$ 2,500.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>12</td>
<td>Advertising</td>
<td>$ 6,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>13</td>
<td>Total expenses</td>
<td>$ 30,950.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>14</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>15</td>
<td>$ 1,050.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>17</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>18</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>19</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>21</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>22</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>25</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>26</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>27</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>28</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>29</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

If you want to examine the effects of two input variables on a single formula, you can use a two input data table.
To build a two input data table, first choose an empty cell and enter a reference to the formula you want to examine. Using the same consulting firm example as before, we will choose cell E2 and enter the reference =C15 for the Profit formula.

The next step is to create two variable ranges. One range will be a column starting in the cell immediately beneath the formula cell and the other range will be a row starting on the immediate right of the formula cell. This means that the formula cell (E2) will be at the upper left corner of the two input data table. For the column of input variables, we will again use the number of clients. For the row of input variables, we will use the Fee Per Client. (The formula for the Profit values is indirectly dependant on both of these variables.)

After entering some hypothetical values for the number of clients in cells E3:E15 and some different client fee values in cells F2:J2, we will end up with a worksheet something like this:
(Shading, labels, and currency formatting have been added to the data table for clarity.)

The next step is to invoke the data table dialog. This time, the formula referenced in E2 will be evaluated once for every combination of Clients and Client fees, that exists in the table.

First we will select the range of data cells E2:J14 and then we will choose the data table option from the What If Analysis menu.

This time, we have two input variables: one corresponding to the row of Client fees and one corresponding to the column containing the Clients data.

In the Row Input Cell text area type C4, because the row of client fees corresponds to cell C4 in the original data. Similarly, in the Column Input Cell, type C3. The Data Table dialog box should look like this.
It is now just a matter of clicking the OK button to complete the table.

Now the data table contains speculative profit values based on the number of clients and the fee per client.

**Using Goal Seek**

Goal Seek is another useful what-if analysis tool provided by Excel. With Goal Seek, Excel will find a value for a specified cell that makes a given worksheet formula equal to a value that you define. In other words, you can set a formula to a value (goal) that you would like to attain, and then specify one of the cells that the formula references as a cell that Excel can adjust in order to reach the goal.

Take the following worksheet as an example.

The worksheet clearly shows a negative profit (loss) for the current worksheet values. We can use Goal Seek to find a breakeven point based on changes to a cell that is referenced (directly or indirectly) by the profit formula in cell B8. The profit formula is Total Income - Total Expenses, or B4 - B7. Cell B2 contains the number of units sold. This will be the cell that we will adjust to break even.
First, select cell B8 (the cell with the profit formula), and then invoke Goal Seek by choosing the Goal Seek option from the What-If Analysis menu on the Data tab.

Cell B8 is entered into the Set Cell text field, because that is the cell that you selected just before invoking Goal Seek. In the To Value text field type 0 and in the By Changing Cell field enter B2 (by typing it in directly or by clicking with your mouse). The resulting Goal Seek box should look like the following.
If you click the OK button, Goal Seek will find a value for Cell B2 (Units sold) that will make the profit equal to 0 (break even).

The Goal Seek Status box reports that a solution has been found. You can see the value 300 in cell B2. This means that if all other variables remain unchanged, you must sell 300 units to break even. Clicking the Cancel button will restore the original worksheet values, and clicking OK will enter the Goal Seek solution values into the worksheet.

You can just as easily use Goal Seek to find the price per unit or the cost per unit that would make the worksheet break even.

**Using Solver**

Sometimes, when dealing with more complex problems, Excel data tables or the Goal Seek feature cannot provide the kind of forecast or analysis you are looking for. In this type of situation, Excel 2007’s Solver feature might be able to help.

The solver is an Excel feature that is designed for optimizing systems of equations subject to specific constraints. The solver can be used to find optimal solutions for linear programming problems involving multiple equations and multiple unknowns. An optimal solution might be one that maximizes profit, or it could be one that minimizes costs. Basically, the optimal solution will depend on the context of the situation and what you are looking for.

If you are trying to solve a complex problem, the solver will require certain information for it to work correctly. You will have to designate a formula that references the unknowns you want to solve for, and you will have to define constraints that model the given situation. The best way to get an idea of how solver works is to see it used in an example.
First, since solver is an Excel add-in, it may not yet be installed. You can check this by clicking the Data tab. You may see the Solver button to the far right of the tab.

If there is no solver option, the Solver has not yet been installed. To install the solver, display the Office menu and click the Excel Options button at the bottom.

When you see the Excel Options window, choose Add-Ins from the panel on the left, and then use the drop list at the bottom to specify Excel Add-ins.

When you are ready, click Go to display the Excel Add-ins.

When you see the Excel Add-Ins box, put a check next to the Solver Add-in option in the available add-ins list and click OK. When Excel finishes installing the Solver, you should be able to access the Solver option on the Data tab.
In order to use the Excel solver, you must set up the worksheet correctly. This requires a solid understanding of the problem you are trying to solve.

The following example involves a business that assembles and sells computers. The business sells two desktop models: the Budget PC and the Power PC. The Budget model is less powerful than the other model, but the price is very reasonable. The Power PC has more computing power and storage than the budget model, but it is also more expensive.

```
<p>| | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
<td>E</td>
<td>F</td>
<td>G</td>
</tr>
<tr>
<td>----</td>
<td>----</td>
<td>----</td>
<td>----</td>
<td>----</td>
<td>----</td>
<td>----</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Budget PC</td>
<td>3</td>
<td>1</td>
<td>550</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>Power PC</td>
<td>4</td>
<td>2</td>
<td>1200</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>Total</td>
<td>7</td>
<td>3</td>
<td>1200</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

From the worksheet, you can see that it takes 3 hours of hardware labor to assemble the Budget PC and 4 hours of hardware labor to assemble the Power PC. Once the hardware is assembled, it takes 1 hour of software labor to install and configure the operating system and other programs on the Budget PC, and 2 hours of software labor to install all the necessary programs on the Power PC.

Our goal is to find out how many of each type of computer we should make to maximize our weekly total revenue, and what the maximum total revenue would be. To complicate matters, the business employs one part time software installer available for 30 hours of software labor per week, and two full time hardware technicians that provide 80 hours of hardware labor a week. Also, the company that supplies the business with processors can supply only 10 Power PC processors a week.

This means that the total software labor used must be less than or equal to 30 hours for the week and the total hardware labor must be less than or equal to 80 hours. Furthermore, the number of Power PC models we can make in a week must be less than or equal to 10.
The following worksheet is the same as the previous one, except that the cell formulas are now visible. Take your time and examine the cell references in the formulas carefully.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Computer Assembly</td>
<td>Hardware labor</td>
<td>Software labor</td>
<td># Assembled</td>
<td>Price</td>
<td>Revenue</td>
<td>Total SW hours</td>
<td>Total HW hours</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Budget PC</td>
<td>3</td>
<td>1</td>
<td>2</td>
<td>550</td>
<td>=D4*E4</td>
<td>=C4<em>D4+C5</em>D5</td>
<td>=B4<em>D4+D5</em>E5</td>
</tr>
<tr>
<td>5</td>
<td>Power PC</td>
<td>4</td>
<td>2</td>
<td>2</td>
<td>1200</td>
<td>=D5*E5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>total</td>
<td>=D4+D5</td>
<td>=F4+F5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Constraints</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Hardware Hrs &lt;=</td>
<td>80</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Software Hrs &lt;=</td>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td># Power pc &lt;=</td>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td># assembled &gt;=</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cells B4 and C4 hold the number of hardware and software labor hours required to build a Budget PC. Similarly, cells B5 and C5 contain the number of hardware and software hours required to assemble a Power PC. The revenues from the Budget computers can be calculated by multiplying the number assembled by the sale price. (This is what the formula in F4 does.) The revenues from the power computers are calculated by a similar formula in cell F5.

Notice that in both cases, the revenue formulas depend on the number of computers assembled (cells D4 and D5). Because of this, the total revenue formula (F6) is indirectly dependent on D4 and D5.

The formula we want to optimize (also known as the objective formula) represents the total revenue (F6). The cells we will change to maximize the total revenue formula represent the quantities of each type of computer assembled (D4 for Budget PC, and D5 for Power PC).

The constraints for this problem are shown in the green highlighted area. It is not absolutely necessary to label the constraints as they are shown here, but clearly identifying them on the worksheet helps when entering the constraints in the solver. Basically the constraints specify that the hardware hours are to be less than or equal to 80, the software hours are to be less than or equal to 30, the number of Power PC’s that can be assembled is less than or equal to 10, and the number of each type of computer assembled has to be greater than or equal to 0. This last constraint may seem obvious and silly, but it is important to include it so the solver knows that using negative values in the changing cells is not an option when optimizing the objective formula.

The formulas that calculate the total software hours and hardware hours used are in cells G4 and H4 respectively. You should notice that these formulas are also dependent on the number of each computer type assembled.

To summarize, in order to use Excel’s solver you must have a formula to optimize (called the objective formula) and you must have cells that can be changed to optimize the objective. The
cells to be changed should be precedents to the objective formula; that is, the calculation of the objective formula should depend on results in the precedent cells. If constraints are involved, the formulas to be subjected to the constraints should also be dependent on the changing cells.

In the preceding worksheet, Cells G4 and H4 contain formulas that are subject to the constraints. Cell F6 contains the objective formula, and cells D4 and D5 are the changing cells. You should notice that the formulas in cells G4, H4, and F6, are all dependent on the changing cells (either directly or indirectly).

Note: It is assumed throughout that there is enough demand to ensure that every computer made will be sold.

To use the solver, click the Solver button on the Data tab to display the Solver Parameters dialog box.

Place your cursor in the Set Target Cell text box and click on the worksheet cell that contains your objective formula (cell F6 from the preceding worksheet).

Since we want to find the maximum total revenue, select the Max radio button next to the Equal to label. To enter the changing cells, place your cursor in the text area under the By Changing cells heading, and select the appropriate cells from the worksheet with your mouse. If they are non adjacent cells, press the Ctrl button when selecting them. For the problem shown here, the changing cells are D4 and D5.
The next step is to add the constraints by clicking the Add button to the right of the large white constraints area. This will display the Add Constraint box.

![Add Constraint](image)

Place the cursor in the Cell Reference text field, and then select a cell with a formula you want to constrain. In this particular example, cell G4 is selected, which contains the formula for calculating the total software hours used. Follow the same process for the Constraint text field. In this example, cell H11; containing the value 80 is entered. Next, use the drop down list in the center to specify the type of relationship required between the two cells. In this case, the constraint reads G4 <= H11 (that is, total software hours <= 80).

Click OK to enter the constraint into the Solver Parameters dialog box, which now looks like this.

![Solver Parameters](image)

Click the Add button again and follow the same process to enter the cell references for the rest of the constraints:

- Total hardware hours <= 30 (H4 <= H10)
- Number of Power PC’s <= 10 (D5 <= H12)
- Number of Power PC’s >= 0 (D5 >= H13)
- Number of Budget PC’s >= 0 (D4 >= H13)
Here is the resulting Solver Parameters dialog.

![Solver Parameters dialog](image)

Here is the corresponding worksheet with formulas shown.

![Worksheet with formulas](image)

Examine the worksheet so that you understand the relationships between the target cell, the changing cells, and the constraints specified in the Solver Parameters box.
To implement the solver, click the Solve button in the Solver Parameters dialog. If you designed the worksheet correctly, and entered the correct cell references and constraints, you should see the following Solver Results box.

The values that maximize the total profit will now be visible in the changing cells (D4 and D5). The value of the maximum profit will be visible in the target cell (F6). The keep solver solution radio button will be selected by default. If you click OK the new values will remain in the worksheet. If you select Restore original values, the solutions that the solver found will not be entered into the worksheet and the original values will be retained.

You have the option to save the solver results as a scenario that you can name and reload into the worksheet at a later date (refer to lesson 1.4). You can also select one or more report types from the list at the right of the Solver Results box. These formatted reports will be generated on separate worksheets.
This following image shows an answer report based on the solver solution. It is generated on a separate worksheet if you select Answer from the report list in the solver results box.

This is the same worksheet after the price of the Budget PC has been changed to 750; and the solver has been applied with the same target, changing cells, and constraints as before. Notice that because the price has been changed, the solution is now 20 Budget PC’s and 5 Power PC’s for a total revenue of 21000.
Index

Chart
- Chart floor.................................................................................................................. 21
- Creating a chart........................................................................................................ 3
- Moving ...................................................................................................................... 27
- Resizing ................................................................................................................... 24

Charts
- Adding a chart title ................................................................................................. 12
- Adding trendlines .................................................................................................... 18
- As an object in another worksheet ........................................................................... 29
- Axes ......................................................................................................................... 11, 16, 17, 23
- Callouts in ................................................................................................................ 32
- Changes in Excel 2007 ............................................................................................ 2
- Changing axis labels in ........................................................................................... 45
- Changing the source data ....................................................................................... 38
- Changing the type ................................................................................................... 35
- Chart wall ................................................................................................................ 21
- Data labels ................................................................................................................ 15
- Data table ................................................................................................................ 18
- Design Tab ................................................................................................................ 4, 11, 30, 35, 47, 49
- Error bars ................................................................................................................. 19, 20
- Formatting the chart area ...................................................................................... 8
- Formatting the legend ............................................................................................ 5, 14
- Formatting the plot ................................................................................................. 7
- Gridlines .................................................................................................................. 17
- Layout Tab ................................................................................................................. 1
- Saving as a template ............................................................................................... 49
- Series in .................................................................................................................... 41
- Styles ......................................................................................................................... 9
- Type of chart ............................................................................................................ 2

Data Tab ....................................................................................................................... 52, 53, 57, 60, 88, 99, 100, 101, 102, 105, 121, 123, 126

Excel Options
- Installing add-ins ................................................................................................. 123

Goal Seek ..................................................................................................................... 51, 111, 120, 121, 122

Home Tab ................................................................................................................... 85, 88

Input Tables
- Creating single ...................................................................................................... 113
- Creating two input ............................................................................................... 117
- Data Table dialog ................................................................................................. 115, 119
- Formatting ............................................................................................................ 117
- Rules ..................................................................................................................... 112
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single</td>
<td>112</td>
</tr>
<tr>
<td>Two Input</td>
<td>112</td>
</tr>
<tr>
<td>Outlining</td>
<td></td>
</tr>
<tr>
<td>Automatic</td>
<td>52</td>
</tr>
<tr>
<td>Collapsing levels</td>
<td>55</td>
</tr>
<tr>
<td>Expanding levels</td>
<td>55</td>
</tr>
<tr>
<td>Grouping data manually</td>
<td>56</td>
</tr>
<tr>
<td>Removing subtotals</td>
<td>62</td>
</tr>
<tr>
<td>Ungrouping data</td>
<td>59</td>
</tr>
<tr>
<td>Using subtotals</td>
<td>59</td>
</tr>
<tr>
<td>PivotChart</td>
<td>95</td>
</tr>
<tr>
<td>Creating</td>
<td>90, 91, 92, 100</td>
</tr>
<tr>
<td>Frames</td>
<td>90</td>
</tr>
<tr>
<td>Inserting</td>
<td>93</td>
</tr>
<tr>
<td>Populating with data</td>
<td>93</td>
</tr>
<tr>
<td>Refreshing data</td>
<td>90</td>
</tr>
<tr>
<td>Styles</td>
<td>90</td>
</tr>
<tr>
<td>PivotTable</td>
<td>51, 63, 64, 73, 79, 80, 81, 83, 85, 88, 89, 90, 93, 94, 95, 96, 109</td>
</tr>
<tr>
<td>And the Import Data panel</td>
<td>100</td>
</tr>
<tr>
<td>Basics of</td>
<td>63</td>
</tr>
<tr>
<td>Calculations</td>
<td>82, 83</td>
</tr>
<tr>
<td>Classic Layout</td>
<td>See PivotTable, Frames</td>
</tr>
<tr>
<td>Creating</td>
<td>64, 78, 90, 91, 92, 98, 100, 102</td>
</tr>
<tr>
<td>Data area</td>
<td>72, 75, 76</td>
</tr>
<tr>
<td>Data boxes</td>
<td>80</td>
</tr>
<tr>
<td>Data boxes vs. data areas</td>
<td>79</td>
</tr>
<tr>
<td>Data Field Settings</td>
<td>83</td>
</tr>
<tr>
<td>Design Tab</td>
<td>78, 85</td>
</tr>
<tr>
<td>Expanding and collapsing data</td>
<td>68</td>
</tr>
<tr>
<td>Field list</td>
<td>66, 67, 74, 76, 77, 79, 93</td>
</tr>
<tr>
<td>Frames</td>
<td>68, 70, 71, 72, 78, 93, 102</td>
</tr>
<tr>
<td>Manually formatting</td>
<td>85</td>
</tr>
<tr>
<td>Number formats</td>
<td>83, 87</td>
</tr>
<tr>
<td>Options Tab</td>
<td>78, 88</td>
</tr>
<tr>
<td>Page area</td>
<td>77</td>
</tr>
<tr>
<td>Placing</td>
<td>65</td>
</tr>
<tr>
<td>Populating data</td>
<td>73</td>
</tr>
<tr>
<td>Rearranging data</td>
<td>74, 75, 76, 80</td>
</tr>
<tr>
<td>Refreshing data</td>
<td>89, 103</td>
</tr>
<tr>
<td>Removing data</td>
<td>74</td>
</tr>
<tr>
<td>Row and column areas</td>
<td>72, 76</td>
</tr>
<tr>
<td>Source data</td>
<td>64, 65, 71, 88</td>
</tr>
</tbody>
</table>
Styles ......................................................................................................................................... 85
Table Options ......................................................................................................................... 69, 70, 78, 84, 85
Using external data sources .................................................................................................... 65, 96, 101
What is? .................................................................................................................................... 63

Scenarios
Adding ..................................................................................................................................... 106
Creating ................................................................................................................................... 105
Deleting ................................................................................................................................... 110
Editing ..................................................................................................................................... 110
Saving multiple ........................................................................................................................ 110
Scenario Manager ................................................................................................................... 104, 105, 107, 108, 110
Showing ................................................................................................................................... 108
Solver results and .................................................................................................................... 129
Summary reports .................................................................................................................... 108
What are? ................................................................................................................................ 104

Solver
Adding constraints ................................................................................................................... 127
Examples ................................................................................................................................ 128
Implementing solution ............................................................................................................ 129
Installing .................................................................................................................................. 129
Launching ................................................................................................................................ 123
Reports .................................................................................................................................... 129
Results ..................................................................................................................................... 129
Setting up worksheet to use .................................................................................................... 124, 125
Solver Parameters dialog ........................................................................................................ 126
What is? .................................................................................................................................. 122